Doomed to Wordpress

Serious Reflections During the Life of Jeremy Fisher

   

Subscribe
Subscribe to a syndicated feed of my weblog, brought to you by the wonders of RSS.

Flavours
There's more than one way to view this weblog; try these flavours on for size.

  • index
  • circa 1993
  • RSS
  • Links
    These are a few links to my other sites.

  • Ставропигиальныя Пластинки
  • Анкылым
  • Русское Шрифтовое Зало
  • Gopher (Proxied)
  • More about Gopher
  •        

    2016/01/07 updates

    Навязывание обновления софта переходит уже всякие границы. К сожалению, это затронуло и FreeBSD и Perl.

    Решил сегодня наконец обновить порты с уязвимостями. Среди них был libidn (как я потом подумал, непонятно зачем мне вообще нужный). И вот он стал требовать обновить перл до 5.18, хоть ты тресни. У меня шевельнулась, конечно, мысль, что за этим последует обновление половины системы, поскольку перл многое ставил в разные там lib/perl/5.16. Однако я наивно понадеялся, что апгрейд как-то разрулит эту ситуацию. Автоматическое обновление всех зависимых от перла портов также не заказал. Не люблю обновление без объективных причин, коими считаю недостатки непосредственно в обновляемом софте, а не в том, от которого он зависит. Тем более что зависимости зачастую выставлены не пойми по какому принципу, а у меня нету времени с каждым портом разбираться, действительно ли ему нужен такой-то перл.

    Короче, итог: весь день сегодня сижу и обновляю перловые модули. День угроблен. Из-за того, что с какой-то радости разработчикам перла взбрело в голову перейти на нынешнюю систему выпуска релизов. Опять же, я не считаю, что релизы должны выпускаться без объективных причин и что наступление какой-то ежеквартальной даты к таковым причинам относится.

    permanent link